# SCM-Manager (General)

**URL:** https://community.cloudogu.com/c/scm-manager/19.md

[Latest](https://community.cloudogu.com/latest.md) · [Categories](https://community.cloudogu.com/categories.md) · [Tags](https://community.cloudogu.com/tags.md)

---

## [Mercurial Mirroring](https://community.cloudogu.com/t/mercurial-mirroring/1558)

<div class="topic-metadata">

**Author:** [@maximster](https://community.cloudogu.com/u/maximster)\
**Replies:** 2\
**Last updated:** [September 22, 2026, 1:40pm UTC](https://community.cloudogu.com/t/mercurial-mirroring/1558 "2026-09-22T13:40:52Z")

</div>

Hello, I’m trying to setup a mirror of a mercurial repo. In the SCM options I see only SVN and GIT filters for a mirror type. Is there a way to setup an HG mirror? If not, is it possible to add that somehow, officially …

---

## [SCM-Manager 3.12.0](https://community.cloudogu.com/t/scm-manager-3-12-0/1556)

<div class="topic-metadata">

**Author:** [@pfeuffer](https://community.cloudogu.com/u/pfeuffer)\
**Replies:** 0\
**Last updated:** [August 25, 2026, 1:32pm UTC](https://community.cloudogu.com/t/scm-manager-3-12-0/1556 "2026-08-25T13:32:49Z")

</div>

Last week we released SCM-Manager version 3.12.0. Take a look at the blog post for more information.

---

## [Optimize SVN Network Performance](https://community.cloudogu.com/t/optimize-svn-network-performance/1549)

<div class="topic-metadata">

**Author:** [@tanh](https://community.cloudogu.com/u/tanh)\
**Replies:** 12\
**Last updated:** [March 9, 2026, 11:24pm UTC](https://community.cloudogu.com/t/optimize-svn-network-performance/1549 "2026-03-09T23:24:02Z")

</div>

Hello cloudogu community, We are currently looking to optimize our SCM-Manager instance specifically for Subversion (SVN) workflows, with a primary focus on reducing latency during metadata queries and maximizing data t…

---

## [IIS Reverse Proxy for SCM-Manager](https://community.cloudogu.com/t/iis-reverse-proxy-for-scm-manager/1514)

<div class="topic-metadata">

**Author:** [@gavd](https://community.cloudogu.com/u/gavd)\
**Replies:** 5\
**Last updated:** [December 15, 2025, 9:30pm UTC](https://community.cloudogu.com/t/iis-reverse-proxy-for-scm-manager/1514 "2025-12-15T21:30:46Z")

</div>

Good morning, I installed SCM-Manager in a Docker Stack Compose container hosted on a Windows Server 2022 machine using WSL. SCM-Manager works correctly when accessed via the localhost:port URL from within the host. I c…

---

## [Error on commit in version 3.11.0](https://community.cloudogu.com/t/error-on-commit-in-version-3-11-0/1545)

<div class="topic-metadata">

**Author:** [@masrcel](https://community.cloudogu.com/u/masrcel)\
**Replies:** 2\
**Last updated:** [December 1, 2025, 8:14pm UTC](https://community.cloudogu.com/t/error-on-commit-in-version-3-11-0/1545 "2025-12-01T20:14:23Z")

</div>

Hey, I have recently encountered an error where I can no longer make commits. The following message always appears: errorcode : CHRM7IQzo1

---

## [Transfer data from SCM version 1.48 to new server version 3.11.0](https://community.cloudogu.com/t/transfer-data-from-scm-version-1-48-to-new-server-version-3-11-0/1543)

<div class="topic-metadata">

**Author:** [@masrcel](https://community.cloudogu.com/u/masrcel)\
**Replies:** 10\
**Last updated:** [November 11, 2025, 9:38am UTC](https://community.cloudogu.com/t/transfer-data-from-scm-version-1-48-to-new-server-version-3-11-0/1543 "2025-11-11T09:38:53Z")

</div>

Hey, I have a problem. We have an old SCM server in version 1.48 in a separate network. Now we have to shut down the network and cannot migrate the server. That’s why we have set up a new SCM server in version 3.11. N…

---

## [SCM-Manager NAS installation guide?](https://community.cloudogu.com/t/scm-manager-nas-installation-guide/1538)

<div class="topic-metadata">

**Author:** [@vnvjan](https://community.cloudogu.com/u/vnvjan)\
**Replies:** 6\
**Last updated:** [October 31, 2025, 10:27am UTC](https://community.cloudogu.com/t/scm-manager-nas-installation-guide/1538 "2025-10-31T10:27:16Z")

</div>

Hi…is there any installation documentation for a Synology NAS’s available? I trying installing the docker image and after fireing up the image I got an java error like this. I already think there is a misconfiguration …

---

## [Startproblem mit Docker Desktop (Windows)](https://community.cloudogu.com/t/startproblem-mit-docker-desktop-windows/1540)

<div class="topic-metadata">

**Author:** [@vnvjan](https://community.cloudogu.com/u/vnvjan)\
**Replies:** 1\
**Last updated:** [October 27, 2025, 7:45am UTC](https://community.cloudogu.com/t/startproblem-mit-docker-desktop-windows/1540 "2025-10-27T07:45:55Z")

</div>

Ich schreibe das mal in deutsch, ums besser erklären zu können. Umgebung: Win11 Pro + Docker Desktop 4.48.0 + Image 3.11.0 als latest heruntergeladen. Image direkt ohne Container Anpassungen gestartet. Im Log wird de…

---

## [\[AdminPage\] is not a \<Route\> component. All component children of \<Routes\> must be a \<Route\> or \<React.Fragment\>](https://community.cloudogu.com/t/adminpage-is-not-a-route-component-all-component-children-of-routes-must-be-a-route-or-react-fragment/1536)

<div class="topic-metadata">

**Author:** [@stefan22](https://community.cloudogu.com/u/stefan22)\
**Replies:** 4\
**Last updated:** [October 6, 2025, 6:57pm UTC](https://community.cloudogu.com/t/adminpage-is-not-a-route-component-all-component-children-of-routes-must-be-a-route-or-react-fragment/1536 "2025-10-06T18:57:15Z")

</div>

Hallo, Ich habe in scm-manager einige Plugins installiert. Jetzt wird im Administrator Tab folgender Fehler angezeigt: Fehler: \[AdminPage\] is not a component. All component children of must be a or \<React.Fragment\>…

---

## [SCM-Manager 3.11.0](https://community.cloudogu.com/t/scm-manager-3-11-0/1535)

<div class="topic-metadata">

**Author:** [@thomas.zerr](https://community.cloudogu.com/u/thomas.zerr)\
**Replies:** 0\
**Last updated:** [September 29, 2025, 9:32am UTC](https://community.cloudogu.com/t/scm-manager-3-11-0/1535 "2025-09-29T09:32:26Z")

</div>

Today we released the SCM-Manager version 3.11.0. Take a look at the blog post for more information.

---

## [Scm-server 4.0.0-REACT19 WTH?](https://community.cloudogu.com/t/scm-server-4-0-0-react19-wth/1534)

<div class="topic-metadata">

**Author:** [@ckeydel](https://community.cloudogu.com/u/ckeydel)\
**Replies:** 2\
**Last updated:** [September 26, 2025, 1:43pm UTC](https://community.cloudogu.com/t/scm-server-4-0-0-react19-wth/1534 "2025-09-26T13:43:32Z")

</div>

Ubuntu 22.04.5 LTS with Plesk and automatic updates enabled. scm-server runs locally behind an nginx proxy for public access. Today it installed this: scm-server/stable 4.0.0-REACT19 And, as expected(?) it broke the in…

---

## [HTTP ERROR 503 Service Unavailable](https://community.cloudogu.com/t/http-error-503-service-unavailable/1532)

<div class="topic-metadata">

**Author:** [@sten.sogaard](https://community.cloudogu.com/u/sten.sogaard)\
**Replies:** 2\
**Last updated:** [September 18, 2025, 4:13pm UTC](https://community.cloudogu.com/t/http-error-503-service-unavailable/1532 "2025-09-18T16:13:00Z")

</div>

I hope someone can help me, it has been a bad 12 hours of debugging and I am not stuck on the 503 error. I am running scm-manager on a proxmox ubuntu vm and it has been working great for several years. I use it for both…

---

## [SCM-Manager Failed to read repository path database](https://community.cloudogu.com/t/scm-manager-failed-to-read-repository-path-database/1073)

<div class="topic-metadata">

**Author:** [@themsdx](https://community.cloudogu.com/u/themsdx)\
**Replies:** 4\
**Last updated:** [August 25, 2025, 8:17am UTC](https://community.cloudogu.com/t/scm-manager-failed-to-read-repository-path-database/1073 "2025-08-25T08:17:31Z")

</div>

Hi all, I have some problem, we have one ubuntu server where someone installed in the past SCM-Manager, today after rebooting server SCM showing this error someone fight with this or not yet? com.google.inject.Provisio…

---

## [SCM-Manager 3.10.0](https://community.cloudogu.com/t/scm-manager-3-10-0/1527)

<div class="topic-metadata">

**Author:** [@thomas.zerr](https://community.cloudogu.com/u/thomas.zerr)\
**Replies:** 0\
**Last updated:** [August 20, 2025, 12:29pm UTC](https://community.cloudogu.com/t/scm-manager-3-10-0/1527 "2025-08-20T12:29:33Z")

</div>

Today we released the SCM-Manager version 3.10.0. Take a look at the blog post for more information.

---

## [SCM-Manager 3.9.0](https://community.cloudogu.com/t/scm-manager-3-9-0/1522)

<div class="topic-metadata">

**Author:** [@thomas.zerr](https://community.cloudogu.com/u/thomas.zerr)\
**Replies:** 0\
**Last updated:** [August 5, 2025, 12:02pm UTC](https://community.cloudogu.com/t/scm-manager-3-9-0/1522 "2025-08-05T12:02:57Z")

</div>

Today we released the SCM-Manager version 3.9.0. Take a look at the blog post for more information.

---

## [SCM-Manager 3.8.0](https://community.cloudogu.com/t/scm-manager-3-8-0/1496)

<div class="topic-metadata">

**Author:** [@thomas.zerr](https://community.cloudogu.com/u/thomas.zerr)\
**Replies:** 0\
**Last updated:** [April 22, 2025, 10:05am UTC](https://community.cloudogu.com/t/scm-manager-3-8-0/1496 "2025-04-22T10:05:04Z")

</div>

Today we released the SCM-Manager version 3.8.0. Take a look at the blog post for more information.

---

## [SCM-Manager installation problem: sha-1 not supported](https://community.cloudogu.com/t/scm-manager-installation-problem-sha-1-not-supported/1520)

<div class="topic-metadata">

**Author:** [@kryszard](https://community.cloudogu.com/u/kryszard)\
**Replies:** 1\
**Last updated:** [July 29, 2025, 6:33am UTC](https://community.cloudogu.com/t/scm-manager-installation-problem-sha-1-not-supported/1520 "2025-07-29T06:33:17Z")

</div>

I was trying to install scm-manager on Rocky Linux 9.6 and yum ended with this error: warning: Signature not supported. Hash algorithm SHA1 not available. ... Problem opening package scm-server-3.8.0.noarch.rpm. ... Err…

---

## [Importing SVN via API](https://community.cloudogu.com/t/importing-svn-via-api/1509)

<div class="topic-metadata">

**Author:** [@gsink](https://community.cloudogu.com/u/gsink)\
**Replies:** 2\
**Last updated:** [June 2, 2025, 7:21am UTC](https://community.cloudogu.com/t/importing-svn-via-api/1509 "2025-06-02T07:21:44Z")

</div>

I have about 700 SVN repo’s to import, and I’m testing out importing via API but am running into a snag. Update,Got it going with creating a mirror with the following payload, then I’ll come back later and unmirror them…

---

## [Nginx Reverse Proxy Issues - Failed to Fetch](https://community.cloudogu.com/t/nginx-reverse-proxy-issues-failed-to-fetch/1508)

<div class="topic-metadata">

**Author:** [@gsink](https://community.cloudogu.com/u/gsink)\
**Replies:** 5\
**Last updated:** [May 30, 2025, 8:12pm UTC](https://community.cloudogu.com/t/nginx-reverse-proxy-issues-failed-to-fetch/1508 "2025-05-30T20:12:07Z")

</div>

Really having issues getting the reverse proxy setup happy and working. I’ve looked at the documentation and various sample configs I’ve found, but no luck. I’ve switched from Caddy to nginx since there is more document…

---

## [Error message when pushing code](https://community.cloudogu.com/t/error-message-when-pushing-code/1505)

<div class="topic-metadata">

**Author:** [@libinglin](https://community.cloudogu.com/u/libinglin)\
**Replies:** 1\
**Last updated:** [May 14, 2025, 7:54am UTC](https://community.cloudogu.com/t/error-message-when-pushing-code/1505 "2025-05-14T07:54:55Z")

</div>

hello I encountered this problem while using SCM Manager 3.8.0. Error message when pushing code. The server logs are as follows： 2025-05-13 16:37:35.207 \[HgHookWorker-1\] \[DhUl44MCfW\] ERROR sonia.scm.repository.spi.HgH…

---

## [Push to create new repository](https://community.cloudogu.com/t/push-to-create-new-repository/1498)

<div class="topic-metadata">

**Author:** [@ghutchi1](https://community.cloudogu.com/u/ghutchi1)\
**Replies:** 1\
**Last updated:** [April 25, 2025, 7:10am UTC](https://community.cloudogu.com/t/push-to-create-new-repository/1498 "2025-04-25T07:10:58Z")

</div>

Hi, I am running release 3.80 and would like to find out if it possible to do a push to the server which will create a new repository. Thanks. Geoff.

---

## [SCM-Manager 3.x: Unable to Migrate More Than 100 Repositories](https://community.cloudogu.com/t/scm-manager-3-x-unable-to-migrate-more-than-100-repositories/1459)

<div class="topic-metadata">

**Author:** [@0xtrivi](https://community.cloudogu.com/u/0xtrivi)\
**Replies:** 3\
**Last updated:** [March 14, 2025, 6:58am UTC](https://community.cloudogu.com/t/scm-manager-3-x-unable-to-migrate-more-than-100-repositories/1459 "2025-03-14T06:58:06Z")

</div>

I am currently using SCM-Manager version 1.47 and need to upgrade to a 3.x version. Following the official documentation, I first migrated to version 1.60 to make the jump to 3.x. Note: The .deb package from the offici…

---

## [SSH keys of type ed25519 not working anymore](https://community.cloudogu.com/t/ssh-keys-of-type-ed25519-not-working-anymore/1445)

<div class="topic-metadata">

**Author:** [@s.jakobeit](https://community.cloudogu.com/u/s.jakobeit)\
**Replies:** 5\
**Last updated:** [February 18, 2025, 6:33am UTC](https://community.cloudogu.com/t/ssh-keys-of-type-ed25519-not-working-anymore/1445 "2025-02-18T06:33:19Z")

</div>

They worked in SCM-Manager version 3.6.x bur are not working in version 3.7.\* See Key spec not recognised for ed21559 ssh key

---

## [SCM Manager - Git lfs configuration](https://community.cloudogu.com/t/scm-manager-git-lfs-configuration/1443)

<div class="topic-metadata">

**Author:** [@paolongit](https://community.cloudogu.com/u/paolongit)\
**Replies:** 5\
**Last updated:** [February 13, 2025, 8:23am UTC](https://community.cloudogu.com/t/scm-manager-git-lfs-configuration/1443 "2025-02-13T08:23:32Z")

</div>

Hi, I tried using Git LFS with SCM Manager and noticed that LFS files are stored inside the repository as .blob files within the \\store\\blob folder. Is that correct? I would like to know if there is a way to configure …

---

## [Scm-manager with cloudflare for https](https://community.cloudogu.com/t/scm-manager-with-cloudflare-for-https/1438)

<div class="topic-metadata">

**Author:** [@emeee](https://community.cloudogu.com/u/emeee)\
**Replies:** 5\
**Last updated:** [February 5, 2025, 11:01am UTC](https://community.cloudogu.com/t/scm-manager-with-cloudflare-for-https/1438 "2025-02-05T11:01:21Z")

</div>

I updated from v2 to v3 recently. I did not setup the server’s ssl. However, the V2 can work with cloudflare and support https, when my domain is proxied by cloudflare. But for V3, the cloudflare https does not work. A…

---

## [Can we modify the web UI?](https://community.cloudogu.com/t/can-we-modify-the-web-ui/1437)

<div class="topic-metadata">

**Author:** [@emeee](https://community.cloudogu.com/u/emeee)\
**Replies:** 2\
**Last updated:** [February 4, 2025, 3:15am UTC](https://community.cloudogu.com/t/can-we-modify-the-web-ui/1437 "2025-02-04T03:15:41Z")

</div>

If we want to customize the webUI, can we directly modify the page code like html to do it? If so, which folder are these files in?

---

## [Admin password not working after upggrade from v2 to 3.7.1](https://community.cloudogu.com/t/admin-password-not-working-after-upggrade-from-v2-to-3-7-1/1433)

<div class="topic-metadata">

**Author:** [@fabio.parodi](https://community.cloudogu.com/u/fabio.parodi)\
**Replies:** 4\
**Last updated:** [February 3, 2025, 7:38am UTC](https://community.cloudogu.com/t/admin-password-not-working-after-upggrade-from-v2-to-3-7-1/1433 "2025-02-03T07:38:42Z")

</div>

hello I did upgrade scm server from v2 to 3.7.1 After that, the web interface refuses to login with the scmadmin credentials or any other credentials. git and mercurial are still working - I am able to push-pull. so s…

---

## [Upgrade instruction from v2 to v3](https://community.cloudogu.com/t/upgrade-instruction-from-v2-to-v3/1435)

<div class="topic-metadata">

**Author:** [@mysxycht](https://community.cloudogu.com/u/mysxycht)\
**Replies:** 1\
**Last updated:** [February 3, 2025, 7:12am UTC](https://community.cloudogu.com/t/upgrade-instruction-from-v2-to-v3/1435 "2025-02-03T07:12:55Z")

</div>

My scm-manager is run on Docker using the official docker image. I am trying to upgrade it to the new version. I downloaded the 3.7.1 docker and mapped /var/lib/scm folder to my scm home folder. The new system works. Ma…

---

## [SCM-Manager 3.7.0](https://community.cloudogu.com/t/scm-manager-3-7-0/1429)

<div class="topic-metadata">

**Author:** [@pfeuffer](https://community.cloudogu.com/u/pfeuffer)\
**Replies:** 0\
**Last updated:** [January 27, 2025, 9:09am UTC](https://community.cloudogu.com/t/scm-manager-3-7-0/1429 "2025-01-27T09:09:32Z")

</div>

Today we released the SCM-Manager version 3.7.0. Take a look at the blog post for more information. In addition, we also want to mention our security warning. Even if you haven’t updated to 3.x yet, please consider upd…

---

## [Creating a new initialized repo leads to error](https://community.cloudogu.com/t/creating-a-new-initialized-repo-leads-to-error/1418)

<div class="topic-metadata">

**Author:** [@chen.ryan](https://community.cloudogu.com/u/chen.ryan)\
**Replies:** 7\
**Last updated:** [January 13, 2025, 8:18am UTC](https://community.cloudogu.com/t/creating-a-new-initialized-repo-leads-to-error/1418 "2025-01-13T08:18:16Z")

</div>

Creating a new initialized Mercurial repo leads to an error. The webpage states “unknown error”. I’m running a new instance of SCM-Manager 3.3.0 on Windows 10 This is what the scm-manager logs gives me 2024-12-13 16:18…

[Next page](https://community.cloudogu.com/c/scm-manager/19.md?page=1)
