Error: Cannot read properties of undefined (reading 'call')

Hii, I host scm-manager on my vps. I upgrade with debian to revision 2.33.0 from 2.32.something
I select to keep my server-config.xml file.

then I change path from /scm to / in some config files and port and IP… because upgrade overwrite some of them.

  • when I try to go to Users, Groups or Administration page, I find this error message: Error: Cannot read properties of undefined (reading ‘call’)
  • Repository browsing page work, but if I click on any repository, I can not open any of them !!
  • Create new repository → same problem. please help !

Thanks.

NO: I update java from java-15-oracle to jdk-18. reboot the vps ← I wrote this but it is wrong
YES: i reboot the vps without switch to jdk-18, so java-15-oracle is used.

Now, Users, Groups or Administration page work, BUT REPOSITORIES page from main menu DO NOT WORK (mydomain/repos/ ) !! OH MY GOD ! WTF ??

I f I search any repository on the search bar, the search bar work and the repos page list all repository that match the search word.
All website work, only mydomain/repos/ do not work. So I can not create new repository. WHY ??

Now I understand that I need JRE or JDK 1.8 so version 8.
I downloaded the server version-jre-8u331-linux-x64.tar.gz

BUT THE PROBLEMS REMAINED.

Users, Groups or Administration page work, BUT REPOSITORIES page from main menu DO NOT WORK (mydomain/repos/ )

Hey @giovannimanzoni

We would try to recreate your issue on our machines. Is there any way you could share your configuration with us?

My first guess would be that your change regarding the /scm in your basepath could have broken some frontend routes.

Which plugins do you have installed? Could you try and check your browser console which property is actually undefined?

BR
Eduard

Thankyou !

I must say that I am annoyed at always having to change the path /scm to / in the various configuration files, I am thinking of leaving the default path /scm… or can you plan to provide a field for custom route or to load from root ? I think I am not the only one who love put each service on a dedicated domain…

Oh ! This morning I reboot the vps for an system update… then I read the notification about your message, so I log in to my scm account and boom ! All website is working. So… it is strange… not ?

But anyway, installed plugin:
Statistic 2.1.4
Legacy 2.33.0
Git 2.33.0
Mercurial 2.33.0
Subversion 2.33.0

I think this thing I think this has happened 3 days ago also, when in my last post I rebooted the vps and before i did it, only the repository page worked and after restarting it, everything worked except the repository page. now after the umpteenth time, everything works. maybe there is a timeout problem in the initialization of scm-server ? I currently have 106 repositories…