Repo Branches returns 404

Hello everyone,

yesterday we tried to integrate the Pull Request feature into our SCM Manager instance but when we tried to create a pull request, we figured that some braches of the repository returns a 404 error.

When we commit, fetch, pull and push via these branches we do not get any error from the Git clients, but when we try to interact with these branches via the SCM Manager web GUI we keep getting the 404 error not found.

I have tried to restart scm server but to no avail.

Server details:
RHEL 8 Enterprise edition
Apache 2.4.37
SCM Server: 2.30.1


In the /var/log/scm/error_log there are no useful info there.

Thanks in advance.

Cheers

Hi,

when you use Apache as a reverse proxy, do you have set the option AllowEncodedSlashes NoDecode?

(see our reverse proxy documentation)

Regards
René

Hello,

I fixed this.

The issue was I had my default virtualhost set to 443 so adding the AllowEncodedSlashes

to the ssl.conf file fixed everything.

Thanks for your time.

Cheers
Chris

1 Like