How to set idleTimeout in 3.0x

SCM-Manager Docker Container
NGINX Reverse Proxy

When checking out large SVN Repositorys (>20GB) the checkout stops at roughly 1000MB of Data. With an XML Error. Then Cleanup the Checkout and can checkout 1000MB again … and repeating

In The past I got around the issue with the following option in the server-config.xml

<Set name="idleTimeout"> <SystemProperty name="jetty.timeout" default="300000" /> </Set>

Unfortunatly I upgraded to the 3.X Version and can’t downgrade to 2.X Version
How can I set the option in the 3.x config.yml or an other configuration file.

Hey @fragezeichen91 ,

we just released version 3.0.2 with an additional option idleTimeout in the config.

Please let us know if this works for you.
Thank you for your patience and for reaching out to us!

René

1 Like

Still not working for me. No messages in Serverlog aswell.

Hey @fragezeichen91,

currently we cannot reproduce your described issue. Could you please share your nginx config with us? Also, are there any useful informations in your nginx logs?

BTW, we noticed that you set your idle timeout prior to 300.000 ms and now it seems to be only 30.000 ms? Could you also try to increase this please?

Hi, I just managed to reproduce this error using an nginx and the local network. After setting the idle timeout to a higher value, the error vanished. So chances are high, that this is just due to the missing 0.

Hey @fragezeichen91 just want to follow-up. Did this fix our issue?