New subversion repo doesn't show source code in web view

I just created a bunch of subversion repos and imported source code into them. All of them but 1 is fine. this one shows no source code in the web view and says No sources found for this branch.
but I can checkout the repo and the dirs and files are present.

Hi,

can you run a health check on this repository (this can be found in the settings for the repository)? Maybe this can get some hints.

Regards
René

I clicked on the button to run a health check and it doesn’t seem to do anything. Where would I find the results if it ran?

I refreshed the browser and tried again. It seemed to do something this time, but still not sure where to find the results? Also, if I click on commits, I see them and then if I click on sources, they are present. But the home page shows none.



I noticed that the branches directory was empty, so I deleted it and committed in scm-manager, then the home shows the sources and I re-added the empty branches directory and all seems fine still. This must be a bug.

This sounds strange indeed. It’s hard to reproduce for us, though (SVN can be a bit complex). If you find a way to make this reproducable, we would love to take a look.

A health check runs in the background once it’s triggered. You will only get a result, if there are errors, otherwise you will get no explicit result (apart from the fact, that the repository is editable and has no error tag).