Scm-manager 3.x helm deployment not working

  • bug description (occurred issue):
    I just made a fresh scm-manager helm installation (under RH OpenShift v4.14.x) and got stuck when opening the start web page. I only get a picture with spinning lines and text “loading plugin information” below:

  • expected result / system behavior:
    the Login window should appear

  • observed result / system behavior:
    I could not see anything useful in the logs. I even tried to raise the log level.

  • SCM-Manager version and installed package:
    I tested several versions. All installments with v2.x are working without any issues. The problem arises with version 3.x, from 3.0.x through 3.1.x.

(Please also add Screenshots of the issue + if possible a trace created by the SCM-Manager support plugin)
I provided a screenshot above, but I cannot generate a trace, because I do not come that far in the configuration process. Please see the helm values.yaml below:

extraEnv: |
  - name: "TZ"
    value: "Europe/Zurich"
  size: "80Gi"
    cpu: 1
    memory: 2048Mi
    cpu: 50m
    memory: 1152Mi
  type: ClusterIP
  port: 8080

I could solve the issue with the following config entry:

## Evaluates headers set by a reverse proxy like X-Forwarded-For, X-Forwarded-Proto and X-Forwarded-Host
forwardHeadersEnabled: true

Thanks anyway,

1 Like

Hey @mforrer thank you for sharing your solution :pray:

1 Like

Hey @mforrer , sorry for the late reply. Enabling the forward headers should have been done by setting ingress.enabled to true in the config.yaml. May I ask if you had done so? If this is the case, we’d have to check why the setting had not been applied properly.

Thanks for your input!

Thank you for guiding me to the right setting. That has worked so far.

1 Like

That sounds good. Thanks again for the feedback. Happy conding!