SCM-Manager hosting via nginx proxy broken after 3.0.0 upgrade

We have been using SCM-Manager for years as part of a Ubuntu/Plesk server. Plesk manages the subdomain (scm.our-domain.tld) and the SSL certificate so that we can access the server as


The way we make this work is, in Plesk, giving additional nginx directives for /scm as follows:

location /scm {
	proxy_set_header X-Real-IP         $remote_addr;
	proxy_set_header X-Forwarded-For   $proxy_add_x_forwarded_for;
	proxy_set_header X-Forwarded-Proto $scheme;
	proxy_set_header Host $http_host;
	proxy_pass       http://localhost:32180;

As you can see, we expect SCM-Manager to serve without SSL at port 32180 and after the upgrade, I have modified config.yml accordingly. When I open this port in the firewall and access http://scm.our-domain.tld:32180/scm, everything works as expected. But accessing the https link no longer works. Instead, I see SCM-Manager “loading plugin information” with the three spinning circles like this:
Again, this has worked for years without any issues and only broke after last night’s auto-update to version 3.

1 Like


We’re seeing the same issue on our instance but with Apache - also https → http on internal port.

The symptoms are the same - hanging on “loading plugin information”.

Kind regards


Same issue on my instance. Is it a bug?

In software development terms, this is called a regression. I just reported it also in GitHub here:

Have you tried to the the config variable forwardHeadersEnabled to true? I had the same issue and forwardHeadersEnabled: true solved it.


Yes, that fixed it. Thanks!

Works for us too. Thank you for pointing it out!