Svn repository relocated after scm upgrade from 1.6 to 2.3

I’ve upgraded scm to 2.3 from 1.6.
My setup is running behind nginx proxy which handles https calls and proxies them into localhost:8080.

I’ve installed the new version, ran it and went through the migration wizard. After that the manager was stuck on ‘loading plugins information’. After some investigating I saw that the plugins call was made to http://myDomain:443/scm/… instead of https. The only way I was able to solve this is by adding the following line to nginx:
add_header ‘Content-Security-Policy’ ‘upgrade-insecure-requests’;
This solved my web ui issues but working with svn is still a problem.
Scm insists that the repository has been relocated to http://myDomain:443/scm/
for some reason ‘scm’ is insisting on working with http and not https. When I look at the repository settings through the web ui it tells me that to check out the command is:
‘svn checkout http://myDOmain:443/scm…’
Any ideas on how to solve this problem?

Hi, my first approach here would be to configure your base url in “Administration” → “Settings” → “General” to your correct https://myDomain/scm/... url with “https”.

I’ve done that, should of mentioned it. It doesn’t help

I now see that I’ve been looking at it in a wrong way. I thought my problem was that for some reason the server does not understand ‘https’ on these non browser calls. However I now see that I didn’t notice that the problem is that my repo location actually changed during the upgrade. In version 1.6 my repo path was
now it moved to /scm/repo/svn/…
Is there a way to move it to the correct location?

Sorry, for Git and HG we managed to create redirects with the “legacy plugin”, so that old repositories will still work after migration without changing the configuration. SVN though does not accept these redirects and only shows a message that the repository has moved (I don’t know, whether the can be configured otherwise).

The URLs cannot be changed in SCM-Manager.


Since it is not an https problem I can easily relocated the local copy to the new location. No Worries.

I have closed this thread since there was no activity in the last 30 days.