Trouble committing after import of repository from 1.6.0

Hi, we’re currently trying to move all our repositories from scm manager 1.6.0 to 2.42.2 - Importing the dump works, as does the checkout. But when we try to commit a change in the repository, we receive the error E155011 mentioning the file is out of date. What might be the problem and is there a solution? Any help would be appreciated, thanks!

Here are our steps in detail (original language was german, hope I translated it back correctly)

-getting a dump of the repos from scm-Manager 1.60 via svnadmin:
svnadmin dump /var/repos-global/reponame > reponame.dump

  • Import in SCM.Manager 2.42.2 via webinterface:
  • import repository
  • import without meta data or compression

-Checkout via svn checkout url/repo/svn/reponame works

when committing:
user@host:~/test/reponame$ svn commit
Send dev/config.php

svn: E155011: Transfer failed (details follow)
svn: E155011: File »/home/user/test/reponame/dev/config.php« is out of date
svn: E160013: »/repo/svn/reponame/!svn/ver/97/dev/config.php« path not found

Hey, you perhaps tried this already but did svn update help? Also are your sure that your url is right? Can you access this file via curl /repo/svn/reponame/!svn/ver/97/dev/config.php?

Just to mention it. There are several SVN compatibility issues depending which version you used before. You can change that in your global Subversion settings.

Thanks a lot for the reply - we’ve had some other trouble unfortunately and were just now able to check your suggestions.
Yes, we tried svn update and it unfortunately didn’t help. We can’t access the file via curl, there’s also a 404 not found reply.

We’ve checked the subversion compatibility - on both servers we work with version 1.6. and format 4, so this doesn’t help either…are there any more suggestions? Thanks again!

Still couldn’t find a solution, unfortunately…any other suggestions? Thanks in advance!