Using wget to download sources from SCM-Manager/SVN repository

Hi, need some help to download sources via wget from a SVN Repository which I´m using in SCM-Manager. In general, using svn client might work. But in my situation, I have a system without any chance connecting to a repo to download the necessary package. So, the only option is wget. Connecting to subversion service, I am able to download with the following comand: wget -d --user=username --ask-password --no-check-certificate (if needed) https://IP/repo/name/trunk/

Running this against the SCM-Manager currently using: wget -d --user=username --ask-password --no-check-certificate https:/IP/scm/repo/namespace/reponame/trunk/ it always creates just a file which is absolutely not the same as the one I´d like to see. Independant which file I try to download, it contains always the following:


<base href="/scm">

<link rel="stylesheet" type="text/css" href="/scm/assets/ui-styles.css">
  var modernBrowser = (
    'fetch' in window &&
    'assign' in Object
  if ( !modernBrowser ) {
    var scriptElement = document.createElement("script");
    scriptElement.async = false;
    scriptElement.src = "/scm/assets/polyfills.bundle.js";

You need to enable JavaScript to run this app.

  This HTML file is a template.
  If you open it directly in the browser, you will see an empty page.

  You can add webfonts, meta tags, or analytics to this file.
  The build step will place the bundled scripts into the <body> tag.

  To begin the development, run `npm start` or `yarn start`.
  To create a production bundle, use `npm run build` or `yarn build`.
  window.ctxPath = "/scm";
  window.scmStage = "PRODUCTION";
<script src="/scm/assets/runtime.bundle.js"></script>
<script src="/scm/assets/vendors~webapp.bundle.js"></script>
<script src="/scm/assets/webapp.bundle.js"></script>

What needs to be done to be able to use wget also in combination with the SCM-Manager / SVN repo?

Cheers, Sascha

Hey Sascha,

this is because you download the html page instead the direct file.

Try the rest api like this:


To get the HEAD revision use -1 . Also you most likely need to use --auth-no-challenge on your wget.

Hope this helps.


Hey Eduard,

thanks for the information. Works fine for me now. May I ask for some information why --auth-no-challenge is needed here? Doesn´t work without it.

Thanks a lot, Sascha

Hi Sascha,

SCM-Manager does not send an authentication challenge for the api, but without this, wget does not send authentication credentials. That’s about it. See for example the reply on this page: 446949 – wget doesn't send Authentication header



Hi René, got it. Thanks for the explanation.

Many thanks and best regards, Sascha

Threads will be closed after 30 days of inactivity.