Open pdf from repository

We use SCM manager for binary file storage, mostly CAD and Solidworks files. If I access the repository directly through SCM interfase I can use right click and download the files.

1

There are also some pdf files coexisting with the other files, and I have two different questions:

  1. Is it possible to grant access publicly to some files (the pdf type in this case) while restricting download to the other files ? Something like what is possible in Google drive where you may access some files in the folder if you have the link to it. Alternatively a way of syncing these files with for example a Google drive automatically would work fine for us, the idea is to automate this workflow and not need to commit the file to different places by hand

  2. If I right click and download the pdf file, everything´s fine. However, if I left click (I use Chrome) the bare bones of the pdf file structure is rendered, not the typical pdf. I apologize if I am not using the right phrasing but I hope you get the idea. Is there a fix for this ?

Hey @josetabisi,

  1. Currently there is no easy solution. Theoretically you could use the anonymous access to achieve this. But you have to allow each file via the PathWP Plugin to be readable by the anonymous user. There is no regex or glob pattern. If you put all public pdf’s into a single directory this could work.

  1. It is the normal behavior to directly open the file. It seems that you are missing a pdf renderer for chrome?

Hey @josetabisi ,

just to be sure: Are you using SCM-Manager 2 or still a 1.x instance?

And we were mistaken in the first answer: There is no solution to restrict read access for single files right now, only for write permissions.

Regards!

Thanks for your comments. Regarding point number 1, I will try the plugin. Is there any specific info ?

Regarding the PDF, as long as I download a pdf from any server on the web, everything is fine, but not if I point to our own server… Any clues ?

Where do I check the version ? It´s been a while since I last touched this.

Ok, so you still can not enable single files. Or maybe never… So I thought but it was worth asking if anything has changed.

What is pathwp good for ? And where is the new repository of plugins please ?

ok, that’s a 1.x version of SCM-Manager. We do not support this one for some time, now, and you should switch to the latest version of 2.x (currently it’s 2.38.1, but maybe we will release 2.39.0 today). The plugin center for 1.x instances is down, too. You should take a look at our migration guide.

As I’ve mentioned aboce, the PathWP Plugin will not help you to give read access for some files only. This one is only about write protection.

1 Like