Password change does not work

Hi,

When trying to change my password, I get the following error message:

Error: Wrong current password

The current password is wrong. Please try again.

Context

PasswordChange: -
User: fralf

Transaction ID 8USuCGLgoUQ            Error Code 8YR7aawFW1

SCM-Manager 2.28.0

Hi,

this starts getting strange. This error is used only, when the given password does not match the current one for the user. And you were able to log in with this user and the password?

You could try to use curl instead like this (maybe even on the server?):

curl -vu scmadmin \
   http://localhost:8081/scm/api/v2/me/password \
  --data '{"oldPassword": "scmadmin", "newPassword": "scmadmin2"}' \
  -H "Content-Type: application/vnd.scmm-passwordChange+json;v=2" \
  -X PUT

But I don’t see how the “change password” dialog should differ from the login dialog.

Thanks for your quick reply. A colleague of mine reported this and I could reproduce this strange behavior on another machine. As a workaround, I changed the password as admin for her. I will keep your curl command in mind if this happens again.

Best regards,
Frank

I tried again directly on the server. It worked as expected. So it must have something to do with our firewall settings.

Thanks for the feedback! :slight_smile: