Running multiple versions on the same machine?

Currently running version 1.55

Wanting to upgrade to the latest version 2.24

The migration tool I assume won’t touch a 1.55 version, so is therefore possible to install 2.24 on the same machine but different port, and gradually move our repos over manually? Don’t want to shutdown the old version until the new version is up and running OK.

The upgrade will change the scm-home directory that you specify. So do not run it unless you have a good backup or you are running it on a test environment. You cannot start a 1.60 after the scm-home folder has been migrated to 2.x.

To run the upgrade, you will have to update to version 1.60 first, so all old data is updated to this release. After this, you can start with 2.24.0. On the first start with the home of 1.60, you will get a page with a migration assistant. Here you can select, where the repositories shall be stored.

Nonetheless, running two instances in parallel should be possible, but not with the same scm-home directory. If you just want to try a SCM-Manager 2 instance without the old data, you can set another scm-home folder and another port. How you can do this depends on your installation. It would be easy and with low risk to do it with docker, for instance.

Hope this helps.

Many thanks for your helpful reply, we will try to upgrade to 1.6 today after doing a full backup, then proceed to 2.24.

We’d love to hear back from you :slight_smile:

We are now at 1.6, a missing repo caused 1.6 to fail to load, but after manually removing the repo from the xml file, it now seems to work.

Now for 2.24 :slight_smile:

yum/dnf only want to install V2.12.

Trying to install 2.24 specifically states:
Error: nothing provides java-11-openjdk-headless needed by scm-server-2.24.0-.noarch

Does 2.24 require updated Java ?

Which os do you use?

SCM-Manager itself runs fine on Java 8 or newer versions, but the rpm has a hard dependency to Java 11.

That yum offers only v2.12 is interesting, we have done the migration from maven to gradle in version v2.13.

Could you explain how you configured yum for the scm-manager repository?

We use Linux 4.11.12-100.fc24.x86_64

Created SCM-Manager.repo in /etc/yum.repos.d

name=SCM-Manager Repository

dnf list | grep scm-server
scm-server.noarch 2.12.0-1 @scm-manager
scm-server.noarch 2.24.0- scm-manager

dnf update scm-server
Last metadata expiration check: 1:17:00 ago on Wed Oct 13 11:32:41 2021.
Dependencies resolved.
Nothing to do.

dnf install scm-server
Last metadata expiration check: 1:17:17 ago on Wed Oct 13 11:32:41 2021.
Package scm-server-2.12.0-1.noarch is already installed, skipping.
Dependencies resolved.
Nothing to do.

Ok, it looks like you are seeing only version 2.12.0, because it is the last version which does not require java-11 it only “recommends” the usage of java 11. It looks like Fedora 24 does not ship Java 11, so dnf shows you the last installable version for you machine.

So I could theoretically ignore that dependency for now and try and install Java 11 at a later date?

Hi, we’ve tried, but we cannot create an RPM that can be installed in Fedora 24 without breaking new installations. There are some other options, though:

  1. Of cause we recommend to update to a current version of Fedora.
  2. If this is no option for you, you can still use the unix package, or
  3. run SCM-Manager with docker.

Both ways you have the downside, that you will not get automatic updates, but to get an impression of SCM-Manager 2 and test the migration, this should serve you well and both ways aren’t complicated. Maybe you can upgrate Fedora, when you’ve decided to migrate to SCM-Manager 2.

I’m afrait that’s all we can offer.


I did a file comparison between 2.12 and 2.24 Unix installations and the only file that appeared to change was the .war file, so I stopped the service, copied the 2.24 war file over and restarted the service. Now it works as a proper service (thanks to the RPM of 2.12) but is at 2.24.

We have no problem doing a manually upgrade as and when needed.

Many thanks for your help!