Trouble running CLI Client

Installed SCM Manager 2.45.2 on an Ubuntu server 22.04.2 LTS some weeks ago. In the meantime we change the base directory, added users an repositories. Now I tried to install the CLI according to this guide:
When running scm I alway get the error Could not read configuration: could not read apikey from keyring: The name org.freedesktop.secrets was not provided by any .service files. It doesn’t matter if i run scm login, scm logout or even scm --help.
To be honest, my first attempt to scm login was probably successful. An API key was generated but I ran into problems so I deleted this key via webinterface to try it again. Now I am stuck with the mentioned error message. Running the command as root does not help either, but I get a different error Could not read configuration: could not read apikey from keyring: exec: "dbus-launch": executable file not found in $PATH

Hey @daniel,

on your first scm login an api key was created on the scm server and stored into your keyring. By calling scm logout this api key should be removed from your key ring again. Have you modified your key ring or the related config manually? The error sounds like your scm-cli may not longer access the system keyring.

Regards, Eduard

Hi @eheimbuch,

thank you for your reply. As I learned, there is no system keyring service on many headless linux distros (Ubuntu server or even WSL). I was able to install the GNOME Keyring daemon.

sudo apt install gnome-keyring
dbus-run-session -- sh
echo -n "your_master_password" | gnome-keyring-daemon --unlock

Now you can use scm CLI in this special shell.